LUTube

University of Leeds

Uploading content to LUTube by Simon Davis (Fri Apr 24 12:27:30 +0100 2009)

LUTube requires Flash Player versions 9.0.115.0+.

The latest version is available here

Introductory video covering the main aspects of getting started with LUTube and uploading your content.

Comments

There are no comments